wsl2의 node기반 프로젝트에서 sqlite3를 사용하기 위해서 설치되어야 할 라이브러리와 설정, 리빌드가 필요합니다.

먼저 sqlite3를 사용하기 위해서는 다음 라이브러리가 설치되어 있어야 합니다.

  • make
  • g++
  • python2 or python3

라이브러리 설치 하기

$ sudo apt install make g++ python3

node에서 python3를 사용하도록 설정합니다.

$ npm config set python python3

node-gyp rebuild

$ npm rebuild node-gyp
$ npm install sqlite3

이렇게 하면, sqlite3가 오류없이 설치되어서 사용할 수 있습니다.

참고자료

Posted by lahuman

댓글을 달아 주세요